«

»

জানু. 21

CCNA পরিচিতি – লেকচার ১৩– একসেস কন্ট্রোল লিস্ট (ACL)

 

  [কোর্সের মূল পাতা | নিবন্ধনের লিংক]

Final security

যতই আপনি এন্টিভাইরাস, ফায়ারওয়াল ব্যবহার করেন। নিরাপত্তার অবস্থা যদি এই রকম হয় । তাহলে বিষয়টা একটু ভাবতে হবে। চলেন আমরা আমাদের নেটওয়ার্কে কিভাবে নিরাপদ রাখতে পারি সেই  বিষয়টা একটু জানার চেষ্টা করি।

 নেটওয়ার্ক নিরাপত্তা :

নেটওয়ার্ক ইঞ্জিনিয়ার এর একটি গুরুত্বপূর্ণ করাজ হচ্ছে নেটওয়ার্কে নিরাপত্তা দেওয়া। এজন্য সিসকো রাউটারে নিরাপত্তা দেওয়ার জন্য রয়েছে একসেস কন্ট্রোল লিস্ট( Access control List) ।

 এখন প্রশ্ন হলো, ACL( Access control List) কি?

একসেস কন্ট্রোল লিস্ট ব্যবহার করে কোন হোস্ট কোন রাউটারকে ব্যবহার করতে পারবে তা বলে দেওয়া যায় সিমিলারলি হোস্ট কোন রাউটারকে ব্যবহার করতে পারবে  না তা বলে দেওয়া যায়।

  ACL  করার উদ্দেশ্যগুলো কি?

  • ট্রাফিক নিয়ন্ত্রণ করার জন্য অথার্ৎ ACL এর মাধ্যমে বলে দেয়া যায় কোন ট্রাফিক গুলো আগে একসেস পাবে।
  • রাউটিং আপডেট কমানো অথার্ৎ রাউটারগুলো তাদের নিজেদের মধ্যে রাউটিং আপডেট বিনিময় করে । বাহির থেকে কোন রাউটার এর আপডেট যেন রাউটিং টেবিলে যুক্ত হয়ে কোন ট্রাফিক তৈরি না করে সেজন্য একসেস কন্ট্রোল লিস্ট ব্যবহার করা হয়।
  • আইপি প্যাকেট ফিল্টারিং অথার্ৎ একসেস কন্ট্রোল লিস্ট এর মাধ্যমে অর্ন্তমূখী ও বর্হিগামী প্যাকেটগুলো ফিল্টার করে নেটওয়ার্কে হাইলি সিকিউর করা যায়।

এছাড়াও নেটওয়ার্কে সিকিউর করার জন্য বিভিন্নভাবে একসেস কন্ট্রোল লিস্ট কনফিগার করা যায়।

 Types of ACL

১. স্ট্যান্ডার্ড ACL

২. এক্সটেন্ডেড ACL

৩. নেইমড ACL

৪. ইনবাউন্ড ACL

৫. আউটবাউন্ড ACL

 

চলেন একটি Standred ACL কনফিগার করি তাহলে একসেস কন্ট্রোল লিস্ট বিষয়টি আমাদের কাছে আরও পরিষ্কার হবে।

মনেকরি আমাদের প্রয়োজন হলো একটি হোস্টকে তার নিজের নেটওয়ার্ক ছাড়া অন্য কোন নেটওয়ার্ক একসেস করতে পারবে না । আর এই হোস্ট এর আইপি হলো -১৯২.১৬৮.১০.১০.

এখন যদি আমাদের নেটওয়ার্কটি এই রকম হয় তাহলে আমরা কিভাবে কনফিগার করব, চলেন দেখি

ACL final

প্রথমে ইন্টারফেসগুলো আপ করি এবং আইপি এসাইন করি:

R1 router interface up command line

Router>en

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#host

Router(config)#hostname R1

R1(config)#interface fastEthernet 0/0

R1(config-if)#ip address 192.168.0.1 255.255.255.248

R1(config-if)#no shutdown

 

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

 

R1(config-if)#exit

R1(config)#interface fastEthernet 0/1

R1(config-if)#ip add

R1(config-if)#ip address 192.168.10.1 255.255.255.0

R1(config-if)#no sh

R1(config-if)#no shutdown

 

R1(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

 

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

 

R1(config-if)#exit

R1(config)#

 

 R2 router interface up command line

Router>en

Router#hos

Router#con

Router#conf

Router#configure ter

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#host

Router(config)#hostname R2

R2(config)#iner

R2(config)#inter

R2(config)#interface fast

R2(config)#interface fastEthernet 0/0

R2(config-if)#ip add

R2(config-if)#ip address 192.168.0.2 255.255.255.248

R2(config-if)#no sh

R2(config-if)#no shutdown

 

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

 

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

 

R2(config-if)#exit

R2(config)#inter

R2(config)#interface fast

R2(config)#interface fastEthernet 0/1

R2(config-if)#ip add

R2(config-if)#ip address 200.20.20.1 255.255.255.240

R2(config-if)#no sh

R2(config-if)#no shutdown

 

R2(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

 

R2(config-if)#exit

R2(config)#inter

R2(config)#interface eth

R2(config)#interface ethernet 0/0/0

R2(config-if)#ip add

R2(config-if)#ip address 192.168.20.1 255.255.255.0

R2(config-if)#no sh

R2(config-if)#no shutdown

 

R2(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

 

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

 

R3 router interface up command line

Router>en

Router#con

Router#con

Router#conf

Router#configure ter

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#host

Router(config)#hostname R3

R3(config)#inter

R3(config)#interface fast

R3(config)#interface fastEthernet 0/1

R3(config-if)#ip add

R3(config-if)#ip address 200.20.20.2 255.255.255.240

R3(config-if)#no sh

R3(config-if)#no shutdown

 

R3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

 

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

 

R3(config-if)#exit

R3(config)#inter

R3(config)#interface fast

R3(config)#interface fastEthernet 0/0

R3(config-if)#ip add

R3(config-if)#ip address 192.168.30.1 255.255.255.0

R3(config-if)#no sh

R3(config-if)#no shutdown

 

R3(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

 

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

 

 এখন একটি রাউটিং (OSPF) এপ্লাই করি :

R1 ospf configuration command line

R1(config)#router ospf 10

R1(config-router)#net

R1(config-router)#network 192.168.10.0 0.0.0.255 ar

R1(config-router)#network 192.168.10.0 0.0.0.255 area 0

R1(config-router)#net

R1(config-router)#network 192.168.0.0 0.0.0.7 ar

R1(config-router)#network 192.168.0.0 0.0.0.7 area 0

R1(config-router)#exit

R2 router ospf configuration command line

R2(config)#router ospf 10

R2(config-router)#net

R2(config-router)#network 200.20.20.0 0.0.0.15 ar

R2(config-router)#network 200.20.20.0 0.0.0.15 area 0

R2(config-router)#net

R2(config-router)#network 192.168.20.0 0.0.0.255 ar

R2(config-router)#network 192.168.20.0 0.0.0.255 area 0

R2(config-router)#net

R2(config-router)#network 192.168.0.0 0.0.0.7 ar

R2(config-router)#network 192.168.0.0 0.0.0.7 area 0

R2(config-router)#exit

 

R3 router OSPF configuration command line

R3(config)#router os

R3(config)#router ospf 10

R3(config-router)#net

R3(config-router)#network 200.20.20.0 0.0.0.15 ar

R3(config-router)#network 200.20.20.0 0.0.0.15 area 0

R3(config-router)#net

R3(config-router)#network

00:30:50: %OSPF-5-ADJCHG: Process 10, Nbr 200.20.20.1 on FastEthernet0/1 from LOADING to FULL, Loading Done

192.168.30.0 0.0.0.255 ar

R3(config-router)#network 192.168.30.0 0.0.0.255 area 0

R3(config-router)#

রাউটিং কনফিগার শেষ হলে আমরা যদি (১৯২.১৬৮.১.১০) আইপি পিসি থেকে অন্য নেটওয়ার্ক এর পিসি পিং করি  তাহলে পিং হচ্ছে। সুতরাং আমাদের রাউটিং কনফিগার সঠিক হয়েছে।

after routing

কিন্তু আমাদের উদ্দেশ্য হলো এই (১৯২.১৬৮.১.১০) আইপি পিসি অন্য নেটওয়ার্কের পিসিকে একসেস করতে পারবে না । চলেন তাহলে দেখি এই কাজটি আমরা কিভাবে করতে পারি।

সবশেষে ACL কনফিগার করি

ACL configuration command line

R1#configure ter

R1#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#ac

R1(config)#access-list 10 d

R1(config)#access-list 10 deny ho

R1(config)#access-list 10 deny host 192.168.10.10

R1(config)#acc

R1(config)#access-list 10 per

R1(config)#access-list 10 permit an

R1(config)#access-list 10 permit any

R1(config)#in

R1(config)#interface fas

R1(config)#interface fastEthernet 0/0

R1(config-if)#ip acc

R1(config-if)#ip access-group 10

R1(config-if)#ip access-group 10 o

R1(config-if)#ip access-group 10 out

R1(config-if)#exit

after ACL

এখন এই (১৯২.১৬৮.১.১০) আইপি পিসি থেকে অন্য নেটওয়ার্কের কোন পিসি পিং করে কোন রিপ্লে পাওয়া যাচ্ছে না । সুতরাং আমরা বলতে আমাদের ACL কনফিগারেশন  সঠিক হয়েছে।

আজকের মতো এখানেই  ACL কনফিগারেশন শেষ করছি। সবাই ভাল থাকেন, সুস্থ থাকেন এই কামনা করি।

Comments

comments

About the author

তিতাস সরকার

আমি তিতাস সরকার। আমি জাহাঙ্গীরনগর বিশ্ববিদ্যালয় থেকে আইটি তে মাস্টার্স করেছি এবং সিসিএনএ পরীক্ষা দিয়ে সিসকো সার্টিফাইড হয়েছি।ইনফরমেশন টেকনোলজি নিয়ে জানতে এবং জানাতে ভাল লাগে, তাই আমার এই উদ্যোগ। আশাকরি আইটিতে ক্যারিয়ার করতে আগ্রহী নতুনদের এই কোর্সটি কাজে লাগবে। আমার সাথে যোগাযোগ করতে পারেন ফেইজবুকের এই লিংকে:
https://www.facebook.com/titas.sarker

Leave a Reply