«

»

মার্চ 19

CCNA পরিচিতি – লেকচার ১৪ – NAT

  [কোর্সের মূল পাতা | নিবন্ধনের লিংক]

example pic

দশ মাস দশ দিন
ধরে গর্ভে ধারন,
কস্টের তীব্রতায়
করেছে আমায় লালন।

শুধু মার্চ মাসের নির্দিষ্ট দিনের জন্য নয়, নারীর প্রতি সব সময় রইলো বিনম্র শ্রদ্ধা ও শুভেচ্ছা।

সবার মনে একটা প্রশ্ন আসতে পারে NAT এর সাথে নারীর আবার কি সর্ম্পক!

আসেন প্রশ্নটা সমাধান করি,

একজন মা তার সন্তানকে দুনিয়ার আলো দেখানোর জন্য যেমন দশ মাস দশ দিন গর্ভে ধারন করেন । তারপর সেই সন্তান এই দুনিয়ার আলো দেখার সুযোগ পায়। প্রাইভেট আইপিগুলোও সাধারণত ইন্টারনেট একসেস পায় না। যখনই প্রাইভেট আইপি গুলোকে পাবলিক আইপি এর সাথে NAT কনফিগার করা হয়। ঠিক তখনই প্রাইভেট আইপিগুলো ইন্টারনেট একসেস পায়।

চলেন এবার NAT সম্পর্কে আরেক টু জানার চেষ্টা করি

NAT কি?

NAT  হলো Network Address Translation. প্রাইভেট আইপি এড্রেস ব্যবহার করে যেন ইন্টারনেট ব্যবহার করা য্য় সেই জন্য NAT  করা হয়।

NAT  করার উদ্দেশ্যগুলো গুলো হলো

  • IPv4 পাবলিক এড্রেস এর সংখ্যা ব্যবহার বৃদ্ধি পাওয়াতে এর সংখ্যা প্রায় শেষ পর্যায়। তাই একটি পাবলিক আইপি দিয়ে যেন প্রাইভেট আইপিকে নেটওয়ার্ক দেওয়া যায় সে জন্য নেট করা হয়।
  • নেটওয়ার্ক সিকিউরিটি বৃদ্ধি করার জন্য NAT কনফিগার করা হয়। অথার্ৎ  যে সকল হোস্টকে ইন্টারনেট সুবিধা দেওয়া প্রয়োজন শুধু সেই হোস্টগুলোর আইপি NAT কনফিগার করা যায়।
  • পাবলিক আইপি প্রত্যেক হোস্টে এসাইন করা কস্টসাধ্য কাজ। তার থেকে একটি DHCP সার্ভার কনফিগার করে, যে প্রাইভেট আইপি ব্লকটি ব্যবহার করা হয়েছে DHCP সার্ভার এ, সেই ব্লকটিকে NAT কনফিগার করে দিলে সহজেই সবাই নেটওর্য়াক সুবিধা পেতে পারে । ফলে নেটওয়ার্ক এডমিনিস্টেস্টশন কমে আসে।

NAT এর Types

Static NAT

স্ট্যাটিক NAT  হলো যদি একটি পাবলিক আইপি এর সাথে একটি প্রাইভেট আইপি এর NAT কনফিগার করা হয়। অর্থাৎ যে NAT এর মাধ্যমে প্রাইভেট আইপি এড্রেস গুলোকে স্থায়ীভাবে  পাবলিক আইপি দিয়ে  ইন্টারনেট দেওয়ার জন্য ব্যবহার করা হয়।

 

Dynamic NAT

ডায়নামিক NAT হলো যখন একাধিক পাবলিক আইপি অনেক গুলো প্রাইভেট আইপিকে ইন্টারনেট সুবিধা প্রদান করে। সে ক্ষেত্রে প্রাইভেট আইপিগুলো ইন্টারনেট ব্যবহারের কাজ শেষ হয়ে গেলে পাবলিক আইপি গুলোকে রিলিজ করে দেয় । ফলে পাবলিক আইপি গুলোকে অন্য প্রাইভেট আইপি ব্যবহার করতে পারে।

PAT

PAT হলো  Port Address Translation.  PAT এর মাধ্যমে একাধিক প্রাইভেট আইপি এড্রেসকে একটিমাত্র পাবলিক আইপি এড্রেস এর সাথে ম্যাপ করতে পারে।

 

আজকে আমরা PAT কনফিগারেশন দেখব। PAT এর মাধ্যমে একাধিক প্রাইভেট আইপি এড্রেসকে একটিমাত্র পাবলিক আইপি এড্রেস এর সাথে ম্যাপ করতে পারে।

চলেন তাহলে শুরু করি

প্রথমে নেটওয়ার্কটি ডিজাইন করি

 s

তারপর ইন্টারফেসগুলো আপ এবং আইপি এসাইন করি

 Interface configuration command line

 For R0 router

Router>en

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#inter

Router(config)#interface fast

Router(config)#interface fastEthernet 0/0

Router(config-if)#ip address 30.0.0.1 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#interface fastEthernet 0/1

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

 

 

For R1 router

outer>en

Router#conf

Router#configure ter

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#inter

Router(config)#interface fas

Router(config)#interface fastEthernet 0/0

Router(config-if)#ip add

Router(config-if)#ip address 30.0.0.2 255.0.0.0

Router(config-if)#no sh

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#inter

Router(config)#interface fa

Router(config)#interface fastEthernet 0/1

Router(config-if)#ip add

Router(config-if)#ip address 20.0.0.1 255.0.0.0

Router(config-if)#no sh

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Routing for router

 

রাউটিং এপ্লাই করি

Apply default routing

For Router R0

Router(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 0/0

For Router1

Router(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 0/0

 

সবশেষে PAT কনফিগার করি

PAT configuration command on Router0

Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255

Router(config)#ip nat pool test 50.0.0.1 50.0.0.1 netmask 255.0.0.0

Router(config)#ip nat inside source list 1 pool test overload

Router(config)#interface fast

Router(config)#interface fastEthernet 0/1

Router(config-if)#ip nat inside

Router(config-if)#exit

Router(config)#inter

Router(config)#interface fast

Router(config)#interface fastEthernet 0/0

Router(config-if)#ip nat

Router(config-if)#ip nat outside

Router(config-if)#exit

Router(config)#

NAT কনফিগারেশন শেষ । এখন যদি আউটপুট দেখি, তাহলে

o

সবাই ভাল থাকবেন।

 

Comments

comments

About the author

তিতাস সরকার

আমি তিতাস সরকার। আমি জাহাঙ্গীরনগর বিশ্ববিদ্যালয় থেকে আইটি তে মাস্টার্স করেছি এবং সিসিএনএ পরীক্ষা দিয়ে সিসকো সার্টিফাইড হয়েছি।ইনফরমেশন টেকনোলজি নিয়ে জানতে এবং জানাতে ভাল লাগে, তাই আমার এই উদ্যোগ। আশাকরি আইটিতে ক্যারিয়ার করতে আগ্রহী নতুনদের এই কোর্সটি কাজে লাগবে। আমার সাথে যোগাযোগ করতে পারেন ফেইজবুকের এই লিংকে:
https://www.facebook.com/titas.sarker

Leave a Reply